403 error — but only for some people?

Big on Hosting. Unlimited Space & Unlimited Bandwidth
This is very weird and I can’t seem to figure out as to why some people who view our website can see and work everything fine while others keep running into 403 and sometimes even the 404 error but mostly 403 forbidden.

Furthermore if you use internet explorer you get 403 error.

http://www.uoforum.com

Our server is a windows server so not sure if the .htaccess does anything but here is the web.config file.

I did not configure this so I’m just wondering if I’m missing something

Code:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <system.webServer>
<defaultDocument>
      <files>
        <clear />
        <add value="index.php" />
      </files>
    </defaultDocument>
    <rewrite>
      <rules>
        <clear />
        <rule name="CanonicalHostNameRule1">
          <match url="(.*)" />
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="{HTTP_HOST}" pattern="^www\.uoforum\.com$" negate="true" />
          </conditions>
          <action type="Redirect" url="http://www.uoforum.com/{R:1}" />
        </rule>
        <rule name="XenForo Rule 1" stopProcessing="true">
          <match url="^.*$" />
          <conditions logicalGrouping="MatchAny" trackAllCaptures="false">
            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
          </conditions>
          <action type="None" />
        </rule>
        <rule name="XenForo Rule 2" stopProcessing="true">
          <match url="^(data|js|styles|install)" />
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
          <action type="None" />
        </rule>
        <rule name="Xenforo Rule 3" stopProcessing="true">
          <match url="^.*$" />
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
          <action type="Rewrite" url="index.php" />
        </rule>
        <rule name="Xenforo Rule 4" stopProcessing="true">
          <match url="^(.*)$" ignoreCase="false" />
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
          </conditions>
          <action type="Rewrite" url="index.php/{R:1}" />
        </rule>
      </rules>
    </rewrite>
  </system.webServer>
<system.web>
        <customErrors>
            <error redirect="http://www.uoforum.com/" statusCode="403" />
        </customErrors>
    </system.web>
</configuration>


Last edited by TheVisitors; Today at 03:19 PM.

This entry passed through the Full-Text RSS service — if this is your content and you’re reading it on someone else’s site, please read the FAQ at fivefilters.org/content-only/faq.php#publishers.

Source

You can skip to the end and leave a response. Pinging is currently not allowed.

Leave a Reply

*